Want pogo help

pogo help phone number recommend you to use internet explorer 11 for awesome game play because it support both java and flash latest version. IE9 and IE10 is no longer supported for it so upgrade your IE browser